AdBook+ System Performance

Incident Report for FatTail

Monitoring

Following a maintenance update at approximately 9:30a PST AdBook+ system performance has returned to normal levels. We continue to closely monitor system health and will leave this incident open.

Please contact us at support.fattail.com with questions.
Posted Jan 26, 2026 - 10:37 PST

Identified

We have identified the issue affecting system performance and are planning to release a fix shortly. Thank you for your patience as we work to restore performance.
Posted Jan 26, 2026 - 09:05 PST

Investigating

We are aware of and urgently investigating an issue with AdBook system performance. Users may experience latency when accessing or navigating within the system.

Further updates will be provided here as soon as they are available.

Please contact us at support.fattail.com with questions.
Posted Jan 26, 2026 - 08:05 PST
This incident affects: AdBook+ System Performance, AdBook+ Order Management, and AdBook+ Salesforce Integration.