AdBook+ System Performance

Incident Report for FatTail

Postmortem

Summary of Impact

On the afternoon of June 22, 2026, users of adbook03.fattail.com and adbook04.fattail.com experienced trafficking errors and slow response time on campaign uploads and reporting.

Performance degradation was first observed and reported at approx. 4:30pm EST. The FatTail engineering team was able to resolve and restore services at approximately 6:25pm EST.

Root Cause

The degradation was caused by elevated request volume that put high pressure on the service caching mechanisms, which caused a slowdown in response time.

Mitigation

There were two steps taken to mitigate the issue:

  1. The reporting services were restarted to clear out orphaned (timed out) requests that were queued up in the caching service.
  2. Cache parameters were updated to provide more resources to handle elevated request volume. 

Next Steps

The team is implementing monitoring to raise alerts when cache resources are out of normal operating zones.

Posted Jul 01, 2026 - 14:17 PDT

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 13:29 PDT

Monitoring

Our engineering team has identified the issue impacting system performance and completed system optimizations. Performance remains stable at this time.

We will leave this incident open for monitoring.

Please reach out via support.fattail.com if you have questions or concerns.
Posted Jun 23, 2026 - 08:07 PDT

Investigating

We are aware of and urgently investigating an issue with AdBook system performance. Users may encounter intermittent errors trafficking lines, checking availability, and running reports.

Further updates will be provided here as soon as they are available.

Thank you for your patience while we work to restore performance.

Please contact us at support.fattail.com with questions.
Posted Jun 22, 2026 - 14:59 PDT
This incident affected: AdBook+ System Performance.